Can't install Scarcity Samurai on

Can't install Scarcity Samurai on

If you've got a hosted Wordpress site, which is different to, you won't be able to install Scarcity Samurai as don't allow the installation of plugins.

In order to install and use Scarcity Samurai you will need to purchase a hosting plan, and then install Wordpress on your server.

Most hosting providers offer a 'one-click' Wordpress install - so it's a very quick and easy process.

Some of the more popular hosting providers include Bluehost, Dreamhost, and Hostgator.

If you run into any issues, please don't hesitate to submit a ticket to support here.

Get in touch

Couldn't find what you were looking for? Ask us a question!